Elasticsearch Log4Shell (CVE-2021-44228)

Norton [CPS] WW

Elasticsearch Log4Shell: Поддерживаемые версии Elasticsearch (6.8.9+, 7.8+), использующие последние версии JDK (JDK9+), не подвержены ни удаленному выполнению кода, ни утечке информации.

Log4Shell

Для поиска уязвимых компонентов в Linux можно использовать различные сканеры.

Использование JDK8

Elasticsearch, работающий на JDK8 или более ранней версии, подвержен утечке информации через DNS.

Устранение уязвимости

Большинство версий (5.6.11+, 6.4.0+ и 7.0.0+) можно защитить простым изменением свойства JVM - Закрытие уязвимости log4shell в Elasticsearch

Log4shell Elasticsearch 5

Elasticsearch 5 подвержен как удаленному выполнению кода, так и утечке информации через DNS. Для версий 5.6.11–5.6.16 это можно уменьшить, установив параметр JVM. Пользователям более ранней версии 5.x рекомендуется обновиться до 5.6.16.

Elasticsearch 2

Elasticsearch 2 и более ранние версии использовали версию Log4j, которая не имеет уязвимости.

Добавить комментарий