Debian cmake: No package 'libpcre' found

При сборке пакета возникает проблема с зависимостью "No package 'libpcre' found"

Текст ошибки

- Checking for module 'libpcre>=8.41'
-- No package 'libpcre' found
-- PCRE version 8.41 or above not found
-- PCRE 8.41 or above not found
-- PCRE 8.41 not found, not building hscollider

Если для сборки пакета требуется версия не ниже 8.39, то устанавливаем зависимости командой

apt install libpcre3-dev

Если требуется версия 8.41, удаляем текущую версию

apt remove libpcre3-dev

и устанавливаем по инструкции Debian установка PCRE 8.41

 

Добавить комментарий